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1. INTRODUCTION 

This comprehensive manual serves as an indispensable resource for students embarking on their 

journey into the world of Heritage BIM (Building Information Modeling). Heritage BIM uniquely sits 

at the crossroads of historical preservation, cutting-edge technology, and innovative architectural 

practices, making it an essential subject for those who aim to bridge the past and future. 

 

The diversity within the realm of Heritage BIM is vast, encompassing a rich tapestry of historic 

structures and architectural wonders, each with its distinct characteristics and historical significance. To 

truly encapsulate the essence of heritage preservation, students need the adaptability to work proficiently 

within various software environments. With this goal in mind, this manual has been meticulously 

designed to facilitate learning across multiple software platforms, with a primary focus on Allplan and 

Revit. 

 

The selection of these software platforms is not arbitrary; it is driven by a commitment to 

versatility. Allplan offers robust architectural planning tools, while Revit is celebrated for its prowess 

in Building Information Modeling. By comprehensively covering both platforms, we ensure that our 

students are well-prepared to navigate the diverse software landscapes they may encounter in their 

professional journeys. 

 

A pivotal theme explored within this manual revolves around the seamless integration of 

previously gathered data into BIM models. This process is not just about digitization; it's a 

transformative journey that bridges the temporal gap between history and the present. We will explore 

the techniques and methodologies outlined in this manual to unlock the true potential of Heritage BIM. 

Through this, students will gain the ability not only to create accurate digital models but also to infuse 

them with invaluable data retrieved from the past. 

 

Heritage BIM's power lies in its universality. This manual demonstrates that by offering examples 

of creating various elements within models of diverse objects, from historic townhouses and industrial 

structures to objects in a state of ruin. Heritage BIM transcends architectural diversity, highlighting its 

adaptability and utility in preserving and documenting heritage structures of all types. 

 

As we delve into these examples, we will learn how to capture the unique essence of each 

structure, regardless of its historical or architectural significance. The principles and techniques 

provided in this manual are universally applicable, ensuring that students are equipped to confidently 

and expertly tackle a wide spectrum of heritage BIM projects. 

 

In the following sections, we will embark on a journey of discovery, delving into the intricacies 

of Heritage BIM. We will acquire the skills to capture the essence of historic structures, navigate diverse 

software environments with confidence, and harmoniously merge the richness of historical data with 

the precision of BIM technology. 

 

Heritage BIM is not just an academic subject; it is a testament to our commitment to honoring our 

heritage while embracing the limitless potential of technology. As we navigate this educational voyage 

with this manual as our trusted guide, we will unlock the world of Heritage BIM and pave the way for 

a future where history and innovation coexist harmoniously. 

 

 

 

 

  



2. CASE STUDY - Allplan 

The Colonia Elioterapica (Heliotherapic Colony) is located in Legnano, a city of about 60.000 

people northwest of Milan. 
In the Lombard industrial context, it was conceived in 1936 for the children of the workers of 

the Cantoni cotton mill in Legnano and financed by Swiss engineer Carlo Jucker, a company executive 

and a man sensitive to the social and humanitarian aspects of its employees as well as to the cultural 

and artistic aspects of the time, in line with both the philanthropic and paternalistic lines of the late 

19th century and the hygienic and pedagogical principles, not unmindful of the fascist period. 

The building was constructed between 1937 and 1938 at the highest point of the city, on the hill 

of Ronchi Park, from which it is possible to glimpse the entire town. It was capable of accommodating 

800 children (400 females and 400 males) during daylight hours and in the summertime. It was 

designed for summer and daytime operation only actually remained in operation for only 2-3 years. 

Completed in 1938, it stopped functioning when Italy entered the war in 1940. It resumed, however, 

after the war, starting in 1946, but with a different function. 

The inauguration took place on June 24, 1938. The project was carried out by the BBPR studio, 

a group of Milanese architects formed in 1932 and consisting of Gian Luigi Banfi (1910 - 1945), 

Lodovico Barbiano di Belgiojoso (1909 - 2004), Enrico Peressutti (1908 - 1976), and Ernesto Nathan 

Rogers (1909 - 1969), authors of important architecture such as, for example, the Torre Velasca in 

Milan and the restoration, with adaptation of the rooms into a museum, of the Castello Sforzesco, also 

in Milan. 
 

The design of the Colonia respects the formal and functional characters of the Modern 

Movement: spaces are studied in the smallest detail considering their functions and mutual relations, 

interior-exterior, interior- interior, exterior-exterior. 

In fact, the floor plan consists of the juxtaposition of two bodies, connected by a pair of covered 

passageways, the whole articulated in the open space into four rooms: the main building, the shed in 

the lawn for siesta, the circular pavilion with services, and the outdoor facilities. The entrance building 

housed the management, two waiting rooms, a consultation cabinet, a medical examination room and 

related facilities, the changing rooms, divided according to the sex of the children. 

The kitchen was a vast hall 15m wide by 10m long. It was equipped with a charcoal oven, two 

sinks and built- in furniture. The special feature of this room lay in its roof: a sloping ceiling with 

vents at the top, which, because of its shape, acted like a large hood. The walls, on the other hand, 

were covered with an enamel paint in the lower part, so that they could be cleaned more easily. In 

addition, the kitchen overlooked a basement room, reached by two external staircases, which housed 

pantries and storerooms. However, the kitchen, which was located in the refectory room, was divided 

from the latter by three portico passages. 

The refectory, consisting of a U-shaped plan with an area of 5240 m3, could accommodate up to 

800 children and took light from a series of high windows, and a sequence of picture windows, placed 

at child height, both located along the two wings of the building. The south façade, thanks to the 

setback of the pillars presented a continuous, openable glazing, so as to provide both ventilation and 

shelter. In addition, the glazing also featured paired two-by-two inward-opening doors. Today, the 

glazed wall is still present, albeit largely degraded. The central interior wall of the refectory was then 

covered in red polished stucco, while the pillars in white, as were the other walls, which, however, had 

a lime plaster covering. Even the interior furnishings, from the kitchens to the locker rooms to the 

refectory, were conceived and designed by BBPR themselves, a symptom of the strong attention to 

functional details of the modern movement. 

The solarium made of larch wood, painted bottle green like the window frames, of which no 

trace remains today, ran along the south front and allowed not only shelter from the sun of the 

windowed front by a series of curtains, but was also able to provide an appropriate and supervised 

place for the heliotherapeutic care of the children. Its dimensions were 2.40m wide, 6.75m high and 

a length of 40.10m equal to that of the glazed wall. 
Within the Ronchi Park, BBPR designed both the green space and the secondary volumes by 

placing, on an axis orthogonal to the facade, two circular pavilions about 10m in diameter, intended 
for showers, washbasins, and lavatories, also divided according to the sex of the children. These were 



specially designed, with a natural system suitable for warming the water intended for the showers. 

Parallel to the main building there was also a large thatch-covered shed to house the children in 

bad weather, for shade breaks and for sheltering equipment. The structure consisted mainly of brick 

with reinforced concrete pillars and concrete-slab floors. 
 

Figure 1 Colonia Elioterapica by BBPR, 19381. 

Source: F.Biccheri, M.Delmedico, G. Garcìa Sànchez, M. Martìnez-Artero Peñalvernomi, Laboratoy of Restoration 

2019/2020, Master Degree of Architettura – Ambiente Costruito – Interni, Politecnico di Milano. 
 

The Colonia Elioterapica was closed in August 1942, occupied by German troops and turned 

into an ammunition depot. After the war ended, it became the headquarters of the Italian Partisans 

Association and was later turned over to the Legnano Hospital. 

In 1954, the hospital administration decided to transform the former Colonia into a center for the 

reeducation to work of those handicapped by injury due to the economic-social problems born of the 

industrial revolution between the 19th and 20th centuries, in fact constituting the first center of its 

kind in Italy. It became more and more necessary, in fact, to rescue, care and re-educate to work those 

workers who, stricken by work injury found themselves impaired in their ability to work. The new 

reeducation center for motulesi from work injury began operations in the summer of 1955. 
 

Figure 2 Colonia Elioterapica from 1956 to 19822. 

Source: F.Biccheri, M.Delmedico, G. Garcìa Sànchez, M. Martìnez-Artero Peñalvernomi, Laboratoy of Restoration 

2019/2020, Master Degree of Architettura – Ambiente Costruito – Interni, Politecnico di Milano. 
 

The original 1938 Colonia complex was partially demolished and then rebuilt: of the original 

group of buildings only one building survived, the one that once housed the refectory and solarium, 

now dilapidated. In fact, the shed and the front body were also demolished, replaced by a two-story 

building. The refectory was divided into three parts: refectory and conference hall, gymnasium (left 

wing) and swimming pool (right wing), while the kitchen retained its purpose. The new building 

housed the inpatient rooms, the medical 
 

1 The triangles symbolize the two separate accesses to the building. The rectangular shaped body 

is the entrance building and it is connected to the U-shaped building, the refectory, and to the kitchen, 

the red body in the middle, by to covered corridors. The solarium is visible in front of the main side 

of the refectory. 
2 Of the original complex, only the body of the previous refectory and the kitchen survive. The original entrance 

building, the two covered corridors and the solarium are demolished and a new body takes place. 



room, while the Colonia was adapted to the physical activity of the motulans. As can still be seen 

today, a gymnasium for rehabilitation exercises, a pool for underwater physiotherapy and various 

outpatient clinics were provided inside. Attached to the facility was later built a church, inaugurated 

and consecrated by Archbishop Giovanni Battista Montini of Milan in 1961, which still stands within 

the area today. 

The Legnano center was taken as a model both in Italy and abroad, but it was closed in November 

1982 and the department transferred to the Traumatology Pavilion of the Legnano hospital citadel. 

Since that time, the remaining spaces of the Colonia have been unused, now severely degraded due 

to neglect and heavily damaged by at least two arson fires. 

Since August 1, 1990, the area of the former Colonia Elioterapica has become the site of the 

psycho-social center, which reports to the psychiatric department of the Legnano Civil Hospital. 
 

Figure 3 Colonia Elioterapica from 1998 to nowadays3. 

Source: F.Biccheri, M.Delmedico, G. Garcìa Sànchez, M. Martìnez-Artero Peñalvernomi, Laboratoy of Restoration 

2019/2020, Master Degree of Architettura – Ambiente Costruito – Interni, Politecnico di Milano. 

 
 

3 To the complex of the 50s – 80s other bodies were added, but the spaces of the original kitchen and refectory have 

been abandoned. 



1.1. Photo narrative  
  

Figure 4 Colonia Elioterapica in 1938: view of the solarium. 

 

 

 

Figure 5 Colonia Elioterapica in 1938: view of the two bodies and the covered corridors. 



 
Figure 6 Colonia Elioterapica in 1938: view of one of the two the circular pavilions for showers. 

 

 

Figure 7 Colonia Elioterapica in 1955: view of the ex - refectory. 



 
Figure 8 Colonia Elioterapica in 1955: view of the continuous facade. 

 

 

Figure 9 Colonia Elioterapica in 1955: view of the new swimming pool. 



 
Figure 10 Colonia Elioterapica in 1988: view of the ex – solarium and the new body. 

 

 
 

Figure 11 Colonia Elioterapica in 1988: view of the new access to the complex. 



 
Figure 12 Colonia Elioterapica in 1988: view of the abandoned kitchen. 

 

 
 

Figure 13 Colonia Elioterapica in 2011: view of the continuous facade. 



 
Figure 14 Colonia Elioterapica in 2011: view of the abandoned showers’ pavilion. 

 

 
 

Figure 15 Colonia Elioterapica in 2011: view of the abandoned kitchen. 



2.1. Survey  

The following will be a schematic illustration of the procedure adopted for the survey of the 

Heliotherapy Colony. It should be noted that the following method is aimed at finding the necessary 

material for the realization of a project proposal, which has as its goal the preservation of the historical 

artifact, which is recognized and listed as a monument. 

2.1.1. Conduction 

Preliminary survey   

Even before the on-site survey, a cognitive investigation of the area and the artifact was carried out 

aimed at finding as many elements as possible, in order to obtain a complete picture of the state of 

affairs and the historical evolution of the building. This preliminary analysis is essential to understand 

the object that is going to be surveyed and to plan and design an accurate survey that can return as much 

information as possible. Information that will be pivotal points for the realization of an appropriate 

conservation proposal. 

Eidotype  

Upon arriving at the Colonia, an inspection was carried out, allowing for an understanding of how to 

proceed with the laser scanner survey. In this regard, the eidotype is used to design the location of the 

targets (appropriately numbered) within the artifact and consequently the station points of the laser 

scanner. Each station point was strategically placed in order to allow as many points as possible to be 

acquired. In addition, at least 3 targets must be clearly acquired from each station point for proper 

subsequent point cloud alignment. 

Laser scanner survey  
Having drafted the eidotype, we proceed with the positioning of the laser scanner, on a suitable 
tripod,at the previously established points. 

Stationing 
Having drafted the eidotype, we proceed with the positioning of the laser scanner, on a special tripod, 
at the previously established points. 

Tolerance setting  
Among the various settings that can be selected before starting the laser scanner, the quality of data 
acquisition is also prente. This is translated into the number of points that are "beaten" by the laser 
and the distance between them. This tolerance must be varied according to the scale at which the 
survey is returned and considering that the scatter of the points increases as the distance itself 
increases. 

Starting the scanner   
The scan is then started, taking care that no obstacle accidentally comes between the scanner and the 
object to be surveyed. 

Photogrammetric survey  
To enrich the information obtained by laser scanner, a panoramic camera is used, placed on the same 
tripod as the station, so as to obtain a 360° photo of the previously surveyed object. 

Repetition of previous points  
We proceed with the survey at the next station point, repeating the previous steps. 

Photographic support  
At the indirect survey by laser scanner, it is also useful to take some significant photographs to 
elements that require attention. By also affixing a measure, such as a meter, to serve as a reference 
system, you will have a complete and detailed picture of what you have surveyed. This will be useful in 

the restitution phase and as support for the material obtained. 
 

Decay and materials survey  

By means of appropriate analysis sheets, photographic support, direct measurements, etc., a complete 



analysis of the degradation of the architectural object is carried out, thus obtaining a complete picture 

of the state of affairs and the general condition of the structure. This phase is essential for evaluating 

the best conservation procedures to be adopted. 

 

2.1.2. Pointcloud 

Prior to any data return operation, it is necessary to process the data obtained using the proprietary 

laser scanner software. At this stage, the point clouds obtained for each scan are aligned and an initial 

cleaning of elements not needed for the purposes of the survey is carried out. Once these steps are 

completed, the file is exported to the desired target format. 

Proprietary software  

Before any data-return operation, it is necessary to process the data obtained using the laser scanner's 

proprietary software. At this stage, the point clouds obtained for each scan are aligned and an initial 

cleaning of elements not needed for the purposes of the survey is carried out. Once these steps are 

completed, you export the file to the desired target format. 

Recap 

Use of the Recap software is useful for immediate analysis of the point cloud. Direct measurements of 

the fabbricate and additional file cleanup can be performed. 

Autocad / Revit  

Once the point cloud is obtained, it is imported (as needed) into Autocad or Revit; then performing a 

file return operation and obtaining the survey the predetermined technical drawings. 

 

2.1.3. CAD restitution 

Return of the drawings   

Once the previous operations are finished, we proceed with the graphic restitution at a scale of 1¬50 

(decided already during the survey phase); Plans, sections and elevations of the building are then 

reported, adequately dimensioned and sufficiently rich in information, including: details at larger scales; 

photographs and mapping of degradations.  



2.2. Examples of data collecting sheets 

Code of the building/ensamble of buildings 

001 

 
Single building n.: …......1........ Portion …......1........ 

Single building n.: …................. Portion …................. 

Single building n.: …................. Portion …................. 

Single building n.: …................. Portion …................. 

Single building n.: …................. Portion …................. 

Single building n.: …................. Portion …................. 

 
Arranging of a list of the data concerning the building and its neighborhood (block, historical 

center)   

Typology of data ● Collection of archive material 
 ● Collection of bibliographical material 
 ● Cartographic collection 
 ○ Collection of cadastral plans 
 ● Collection of geometric surveys 
 ○ Collection of permissions of construction 

 
 

* It is necessary to verify the presence of fixed or mobile furniture of value 

* It is necessary to check for the presence of valuable architectural elements (decorative 
stucco, painted plasters, painted ceilings, valuable floors) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Sketch of the complex and its surroundings. By Marta Rota. 

 
Name of the surveyer: 

 
…..........MARTA ROTA................. 

 
Date of the survey: 01/02/22 
Date of update: …................ 

 



MASER DATA 

 

Code of the single building: 

001 

 

 
Location    

○ Historical center ○ Isolated 

● Surroundings ● Non-isolated 
Address: .....................................VIA RONCHI,99 (20025)........................................................ 

 
Name of the building ......................CPS LEGNANO............................. 

 
 

Property: ● Public 
 ○ Private 

 
 

Date of construction: ...........1938, ENLARGEMENT IN THE 50s...................... 

Designer/Author: …........................BBPR GROUP................................. 

 

 

 

Single building 

Predominantly vertical  Slender  

construction Not slender  

Predominantly horizontal 
X 

Vertically interspersed  

construction Horizontally interspersed  

Others: Vertically and horizontally 
X 

interspersed 

 
Name of the surveyer: 

 
…..........MARTA ROTA................. 

 
Date of the survey: 01/02/22 
Date of update: …................ 

 

 

Administrative position: 

Country .....................ITALY.................................. 

Region ...............LOMBARDIA........................... 

 

Municipality ..................LEGNANO........................... 
Province ..................MILANO........................... 

 

Intended use 
U/G …............NU2................. F. 3 ….............../...................... 

G/F …............NU2................. F. 4 ….............../...................... 

F. 1 ….............../...................... F. 5 ….............../...................... 

F. 2 ….............../...................... F. 6 ….............../...................... 

 

….............../...................... 

….............../...................... 

….............../...................... 

….............../...................... 

 

R = Residential C = Commercial 
D = Directional S = Services 

AA = Agricultural activities LC = Place of worship 

M = Warehouses and deposits K = Church 

NC = Unkwown  

NU1 = Not used for less than 5 years 

NU2 = Not used for more than 5 years 

 

A = Artisanal 
I = Industrial 

B = Box 
X = ……………………………… 

 



2.3. Modeling 

 
During the process of creating the BIM model, starting from the point clouds obtained, the approach 

to organizing the building's plans and modeling its architectural and structural elements has been based 

on the IFC (Industry Foundation Classes) standard. 

Structuring according to the Site_Building_Floor schema allows for the generation of graphical and 

computational information, both point-based and structured for completed works, with a breakdown of a 

Work Breakdown Structure (WBS) that is easily manageable in relation to the final extraction objectives. 

 
The model developed using Allplan solutions (for BIM model management) and Scalypso (for point 

cloud management) has been shared within the BIM+ collaboration platform. Uploading can occur 

directly from the native model, rather than through the upload of IFC files. 

Within the platform, access is only identifiable and planned through user accounts (email addresses) 

corresponding, in an authorization matrix, to the representatives of individual activities and specialist 

models. The platform includes documents related to technical sheets of surveyed components, making 

them accessible through a web browser for project participants present on the platform. 



 

 
2.3.1.  Window 

Vertical closure elements must be reparameterized based on the complexity of the geometry to be 

reconstructed. However, it is possible to create each individual component of the façade/window, 

ensuring the ability to manage and subsequently extract information (both graphical and metric 

computation).



 

2.3.2. Wall 

In the modeling process, the use of point clouds is crucial for capturing geometric information and 

reconstructing elements by reparameterizing them using functions available in BIM modeling software.

 

 

 

 

 

 



Details captured during the survey through photographs can be integrated as pixel mapping directly 

onto a single modeled element.. 

2.3.3.  Column 

The modeling of vertical elements, such as columns, is simplified thanks to the automatic detection 

of closed areas within a two-dimensional floor plan 

 

 

 

 

 

 

 

 

 

 

2.3.4. Bas–relief  

Through the existing integration between Allplan and Scalypso, regarding specific elements such 

as friezes and decorations, as well as the modeling of vertical elements, it is possible to automatically 

recreate 3D surfaces in the BIM model with the goal of transferring certain objects that play an important 

artistic role in the project in a "true-to-life" manner. 
 

 



 

La piattaforma di condivisione BIM+ veicola verso gli utenti inseriti nel progetto, oltre agli 
attribute informative (geometrici e prestazionali) anche eventuali documenti a corredo dell’elemento, 
come ad esempio schede tecniche, disegni CAD, documentazioni di rilievo materico, fotografie ed altro. 

 

 
 

  



2.4. Attributes - examples 

The informational content of the elements is planned at the beginning of the BIM modeling process, 

so that useful information can be shared through the model throughout the Design, Construction, and 

Management/Maintenance phases of the project element. 

Attributes within Allplan can also be managed through an Excel table, simplifying the addition and 

modification of informational content for any element in the BIM model.  

 

 

 

 

 

 

 

 

 

The Excel file remains a direct means of editing and updating information, thanks to the unique 

identifier (Allright_Comp_ID) that links the object in the BIM model to specific information. 

Below, we provide a comparison for each analyzed element of the informational content in Allplan 

and after export to the IFC4 format. 



2.4.1. Window’s attributes – Allplan and IFC 

 



 



 



2.4.2. Wall’s attributes 

 



2.4.3. Column’s attributes – Allplan and IFC 

 
 

 

Attributes with hyperlinks can direct a detailed analysis of the element, allowing the 

opening of technical documentation shared via the internet. In the image above, you can see the 

hyperlink leading to a Technical Documentation. 

 



 



3. CASE STUDY – Revit 

Within the pages of this comprehensive chapter, we embark on a journey into the intricate 

world of modeling historic buildings using the powerful Revit software and the cutting-edge 

technology of Building Information Modeling, often referred to as BIM. Our primary focus is 

on the realm of heritage BIM, where the past meets the future, and where the preservation of 

our architectural heritage relies on the fusion of technology, knowledge, and creativity. 

 

Heritage BIM stands as a beacon of hope for the preservation of our cultural treasures. 

Historic buildings are more than just structures; they are living remnants of our shared history 

and artistic expression. As these architectural gems age, they require meticulous care and 

documentation to ensure their legacy endures. This chapter unfolds the principles and practices 

essential for students and educators to navigate this intricate domain effectively. 

 

Modeling historic buildings is not without its unique challenges. These structures often 

defy convention with irregular shapes, varying dimensions, and intricate details. Thus, the task 

of capturing their essence through modeling demands a deep understanding of both technology 

and artistry. This chapter equips educators and students with the knowledge and techniques 

required to rise to these challenges gracefully. 

 

Throughout this chapter, we explore a spectrum of elements encompassed within the 

domain of modeling historic buildings. From foundational concepts to advanced 

methodologies, students will develop a comprehensive skill set to create accurate and detailed 

BIM models. Key topics covered include point cloud integration, modeling walls, openings 

(doors and windows), and various architectural elements, parametric modeling, proper 

documentation and annotation, and site and context modeling. These insights and practices are 

designed to serve as invaluable resources for educators as they guide their students through the 

fascinating world of heritage BIM, ultimately contributing to the preservation of our 

architectural heritage for generations to come. 

3.1. Combining and Generating Point Clouds 

 In this chapter, we will demonstrate how to combine and generate a point cloud created 

with a laser scanner. The first step is to create a new project with the "Import Scan Cloud" 

option in the ReCap Pro software. 

 
 



 

After importing the scans with default 

settings, you should choose the manual 

registration process. 

 

In the spherical view displayed from the 

first scanner position, select the icon marked to 

designate it as your starting point.

 
 

Next, by navigating the view to the right and left of the screen, locate corresponding 

targets and mark them one by one. Once the program finds similarities, it will display a message 

at the bottom and allow you to merge the scans. 

 
 

Repeat the matching process for all positions, and after completion, you will see a 3D 

view of the entire merged point cloud from all positions. 

 



 
In the top view, select the entire object's surroundings, leaving approximately a 1-meter 

buffer around it. After marking unnecessary elements of the cloud, remove them, leaving only 

the object of interest within the specified range. 

Below is a view of the cleaned and aligned point cloud. After performing these tasks, save 

it in *.rcp format to proceed with the work in Revit, as described later.. 

 

 



3.2. Import and Positioning of Point Clouds 

This chapter will show how to insert 

and position a Point Cloud in the Revit 

software. 

 

For the purpose of this exercise, it is 

assumed that the model will not have shared 

coordinates, and its survey point will be in 

the same location as the internal origin 

point. 

 

To begin, create a new project using 

the Architectural Template or your custom 

template conforming to external standards, 

and change the project units to centimeters. 

 

Open an empty file with basic 

families for BIM modeling in Revit. Insert 

the Point Cloud by going to the Insert tab > Point Cloud: and select the Position: Automatically 

- from the internal origin point to the internal origin point. By choosing this method, you ensure 

that the Point Cloud will always load into the same location, even if it is completely removed 

(Manage>Manage Links) from the model:  

 
The loaded Point Cloud may be in different locations within the model. To locate it, use 

the Site view or 3D view. Then, after locating the Point Cloud, it's a good idea to create an 



approximate section through the building, which will include the Point Cloud, the level range, 

and the project base point and survey point in Revit: 

 
Next, adjust the levels to match the Point Cloud. Then, move the project base point to the 

level 0 height. Keep in mind that Level 0 is an arbitrary level. In historic buildings, floor levels 

may vary significantly. In such cases, it is recommended to average the placement of Level 0 



or place it at the lowest point of the floor, especially if the height differences are substantial 

(e.g., more than 10 cm). Note that the project base point and survey point are hidden by default:  

 
 

Moving on to the views, you can 

easily filter out unnecessary noise by 

adjusting the view range at different 

heights with a shallow depth (e.g., the 

section cut will be at a height of 100 cm).  

 

 

 

 

 

 

  



 The project's north direction should typically be set parallel to the longest external wall 

of the building or the wall with the most walls in the same direction. To do this, it is helpful to 

first draw a Detail Line (DL) along the external edge of a wall, for example, and then orient the 

project's north direction relative to it:  

 

Assuming the Point Cloud is correctly oriented 

relative to the true north. If not, it should be corrected. 

 

This way, the model has been adjusted and set up to begin modeling. 

 

 

3.3. Wall Modeling 

A properly generated and aligned point cloud serves as a kind of foundation used during 

modeling. Our task will be to populate it with models of individual elements of the object in 

Revit. The first element to model will be walls. To begin work related to them, switch to the 

Ground Floor view. 

 

Using the Measure Between Two Reference Points tool, measure the thickness of the wall 

from the point cloud. 

 



 
 

The next step is to create a new wall type based on the measured thickness. To do this, 

go to Architecture > Wall > Edit Type > Duplicate > "Wall-65cm" > Edit.  

 

 
Change the layer thickness to the measured value from the foundation and confirm. 

 



 
Wall modeling is done using the Architecture > Wall tool with the newly created type. 

Set the base constraint as Level 0 and the top constraint as Level 1.  

 
 

After completing these steps, you can start modeling individual walls by adjusting their 

parameters and contour to achieve the desired effect one by one. 



 

3.4. Opening modelling 

In this chapter, we will discuss the principles and examples of modeling two types of 

opening families. For the purposes of this work, it is assumed that the opening families will be 

created independently of window and door families for two reasons: 

Firstly, openings in historic buildings are often irregular and uneven. This means that in 

some cases, it will be necessary to model the opening separately using the Component > Local 

Model option under the Architecture tab. 

Secondly, window and door openings may vary in different locations, even if they have 

the same window or door family. Therefore, if the opening family and the window/door family 

were one family, it would not be possible to accurately replicate the building, as illustrated in 

the diagram below: 

 

 
 

Rectangular Opening Family (for doors and windows): 

 

To begin creating the opening family, select File > New > Family. From the family 

template list, choose Window - Metric*. 

 

If the list of family templates does not appear or appears in a limited range, make sure 

that the family libraries and templates are correctly installed on your computer. The default 

location for family templates is: C:\Program Data\Autodesk\RVT <version>\Family 



Templates\Polish 

 Due to the low repeatability of dimensions for openings in 

historic buildings, the Width and Height parameters should be set as 

instance parameters (element) to control each occurrence of the 

family independently, without the need to create dozens or even 

hundreds of separate types for a single family. To do this, select the 

Width parameter on the Reference Level and change it to an instance 

parameter (element). 

 

Similarly, proceed with the Height parameter on one of the 

elevations. Then save the family and name it according to the 

project's standard: File > Save As > Family > HB_Rectangular 

Opening.rfa. 

The prepared family can be loaded into the project and closed. 

 

                   
 

Thanks to the reference planes that were implemented in the family template from the 

beginning, and by changing the Width and Height parameters to instance parameters, you can 

control the family on the elevation using arrows. This is particularly convenient when you need 

to model many openings with different dimensions.  

 

Please note that the arrows to control the family will 

appear only when the elevation or section view is 

perfectly parallel to the wall where the family is placed. 

If the section or elevation is not parallel, you can use the 

Align (AL.) option to align the elevation or section plane 

with the wall plane and then move it away from the wall 

(e.g., 20cm).. 

 

 

 

 

 

Rounded Opening Family (for doors and windows):  

To start creating the family, select File > New > Family, choose Window - Metric from the 

family template list, and repeat the steps for creating the rectangular family. Save the family as 

HB_Rounded Opening.rfa 

 



 For clarity, you 

can also change the 

units to centimeters in 

the family: Manage > 

Project Units (UN). 

 

Switch to an 

external or internal 

elevation where you 

will begin modeling 

the opening: 

 

To create a 

family with an 

elliptical lintel, you need to prepare its structure in the form of reference planes first. Create 

Reference Plane (RP), edit the Height parameter, and edit the existing rectangular opening 

family to convert it into a rounded opening. An additional element parameter named "Height 

of the Arch" is used to control the height of the arch in the lintel. 

 

 Creating the reference plane:    Creating the parameter: 

 

 

 

 

 

 

You should start editing the opening by attaching a sketch line to the reference planes and 

then connecting the two ends of the line to the additional reference plane created earlier: Modify 

> Align (AL.) 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The next steps include creating lines and an ellipse, deleting lines, trimming the ellipse to 

the rest of the outline using the Trim tool, creating a height dimension, and changing the 

dimension to the previously created "Height of the Arch" parameter. 

 

 

 

 After completing these steps, the family of the rounded opening with a lintel should look like 

the image below: 



 

3.5. Modeling Semi-Circular Window Frames for Historic Building 

In this module, we will explore the principles of modeling semi-circular window frames 

for historic buildings, assuming that the window frames are being modeled to fit existing 

openings. To maintain flexibility, the family will not be hosted, allowing it to be inserted into 

any location, regardless of the shape or parameters of other building components. This method 

is recommended for both beginners and advanced users, as it simplifies the modeling process. 

However, it is important to note that modeling window frames along with openings is best 

suited for advanced users and when dealing with a high degree of repetition, such as more than 

30 instances of the same window frame. 

 

To begin, go to File > New > Family and select the Generic Model (Metric) template. 

 

 
 

This template is designed for various simple families like furniture, basic fixtures, 

handles, parking spaces, panels, and more. By default, this template falls under the "Generic 

Models" category. Change it to "Windows" to access system parameters specific to windows, 

such as Width and Height. 

 



  
 

It is recommended to change the 

family units to centimeters. Next, 

create a framework composed of 

reference planes (RP) to resemble the 

template used for the circular window 

opening. Create a right, left, and two 

upper reference planes, assign 

parameters to them, and establish 

Equal constraints. 

 

Use elevation "Front" in the model to 

parameterize the Height and Arch Height, 

similar to the HB_Semi-Circular 

Window.rfa family. Both parameters should 

be instance parameters 

It is recommended to change the 

family units to centimeters. Next, create a 

framework composed of reference planes 

(RP) to resemble the template used for the 

circular window opening. Create a right, 

left, and two upper reference planes, assign 

parameters to them, and establish Equal 

constraints. 

 

Use elevation "Front" in the model to 

parameterize the Height and Arch Height, 

similar to the HB_Semi-Circular 

Window.rfa family. Both parameters should 

be instance parameters:. 

 

 The next step is to create the outer frame profile. In this exercise, we will create a fixed 



window with a constant frame. To model an operable window, a more parameterized family 

consisting of both a frame and a sash is recommended. Select Create > Extrusion along Path 

and sketch the path, similar to the family opening. 

   

 

 It is a good practice to first draw sketches "in the air" and then use the Align (AL) option 

to attach them precisely to a reference plane. When a family needs to be parametric, and a line 

needs to follow a reference plane, be sure to pin the line to the plane right after using the Align 

(AL) option. 

 

 

 After creating a complete sketch (while pinning both ends of the line) and assigning a 

parameter for Frame Depth and Frame Thickness, finish editing mode by clicking the Finish 

Edit Mode button (only once). Then switch to the reference level to sketch the profile. 



 When drawing smaller elements, it is 

advisable to change the view scale from 1:20 to, 

for example, 1:5. Start sketching the profile by 

drawing a rectangle, which, when extruded, will 

form the frame. After creating the rectangle, 

parameterize its thickness and depth. These 

parameters should be type parameters since 

window profile sizes are often standardized, 

even for historic windows. 

  
 



 After approval, the modeled frame should be visible in the 3D view 

and Front Elevation. To ensure the model's accuracy, change the values of 

the following parameters one by one: Width, Height, Arch Height, Frame 

Depth, and Frame Thickness. 

 

 

 

Conducting a short test to assess the family's 

behavior (by altering its parameters) after 

creating each element is crucial for proper 

parameterization and understanding the 

family's functionality: 
 

 

The next step is to create internal muntins within the window, including one thicker 

muntin (matching the frame's thickness) and additional muntins (with a constant thickness, e.g., 

4cm). In the Front view, extrusions symbolizing muntins will be created, and their thickness 

and depth will be parameterized. 



  
 Creating geometry in families should be approached with a sense of balance. The more 

parameters a family has, the more time-consuming it is to create, and the greater the complexity 

during project editing. 

 

For horizontal muntins, additional reference planes (RP) for muntins with a thickness of 

4cm will be utilized. In family parameterization, maintaining a reasonable balance is crucial. 

The most versatile family has all dimensions parameterized, but an excessive number of 

parameters can lead to a lack of transparency and longer editing times in the project. 

 

 



 
 

Creating rectangular prisms symbolizing window panes works similarly. The 

approximate thickness of the glass is assumed to be 1cm: 

 

 
 



The final step in creating the geometry is to create extrusions 

that will trim the protruding rectangular prisms of the glass and 

muntins. 

Create > Form > Extrusion by FaceThe final step in creating 

the geometry is to create extrusions that will trim the protruding 

rectangular prisms of the glass and muntins. 

Create > Form > Extrusion by Face: 

 

 

 

 

Binding lines to planes should be done with exceptional precision. A single improperly 

attached constraint can disrupt the functioning of the entire family. In this sketch, internal 

reference planes were also used, and lines as well as their endpoints were aligned to them: 

 

  



 
 

Using the options Create > Cut Geometry or Don't Cut Geometry, trim the protruding 

muntins and glass without cutting the main frame: 

 

 
 

To parameterize the material of the muntins and glass, create two material parameters: 

• Frame Material 

• Glass Materia 

This allows you 

to select specific 

materials for the 

family you create in 

the project. 

 

After 

completing all the 

steps, the family is 

ready to be loaded into 

the project. 

 

 

 

 

 

 

 

 

 

 



The family is ready for loading into the project and insertion into previously modeled 

openings: 

 

 

 

 

 

 

 
 

 

 

 

For modeling door joinery in historic buildings, it is suggested to use the generic model 

tool directly within the model. Often, specific doors appear only once in a building, so creating 

parametric families for non-repetitive elements may not be efficient. 

 

To create door elements (e.g., gates), the best approach is to create a section, elevation, 

and plan at the location of the joinery and visualize the geometry of the elements parallelly in 

the Recap program: 

 



Next, by going to Architecture > Component > Local Model and selecting the Door 

Category, you should use modeling tools (similar to modeling a family) to create the door 

joinery as desired. Each case will be unique. 

 

 
 

To hide the door leaf in the plan view, select the modeled element in the Generic Model 

and go to Properties. Choose Overrides for Visibility/Graphics and uncheck the 

Projection/Section box. This way, the geometry won't be displayed in the plan view, and the 

door leaf's operability should be symbolically represented with Detail Lines: Annotate > 

Symbolic Line. 

 

 
 

  

 

 

 

 

 
 

 

  



3.6. Terrain Modeling 

Method I - Modeling Based on Point Clouds 

To begin terrain modeling based on point clouds in Revit, you should create a copy of 

your *.rcp file along with its library. Next, open it, and by manipulating the 3D view, mark and 

remove one by one all building elements and unwanted terrain elements. The final result should 

be a cleaned point cloud representing the terrain around the building.  

 

 
 

Once the terrain is cleaned, export it to the *.e57 format. Import the exported file into the 

CloudCompare software, select and save it as a *.txt file. 

 

 
 

Afterward, in Revit, use the tool: 

Massing & Site > Toposurface > Create from Import. 

 

 
 



Then select Create from File CSV, change the format to *.txt, and choose the created file. 

Set the unit to meters. 

 

 
 

The next step is to align the imported topography mass to the existing model using Rotate 

and Move tools.  

 

 
After aligning the topography mass, select it and choose the Edit Sketch option. Then, on 

the Level -1 plan, create an outline along the outer edge of the object and confirm the edit. 

Remove the inner part of the topography mass. 

 
 



3.7. Floor Modeling and Cornice Component Modeling 

We will model the floor using the Architectural Floor tool, and then customize its type 

with appropriate parameters and a name. 

 

Architecture > Architectural Floor > Edit Type > Duplicate > "Floor-30cm" > Edit 

 

 
 

Change the thickness of the layer to the desired value and confirm the edit. 

 

 
 

After creating a new type, outline the outer contour of the modeled floor on the ground 

floor plan, ensuring the correct elevation settings in the parameters. 



 
 

To model the cornice component, start by selecting the appropriate 3D view of the 

element. Then choose: 

 

Architecture > Model In-Place > Generic Models > OK > "Cornice" 

 

 
 

The next step is to use the Extrusion tool and select a work plane using: 

 

Modify > Set Work Plane > Pick a Plane > OK > "Select the wall plane" 



 
 

Use the Rectangle tool to draw the outline of the cornice with the required thickness and 

confirm. 

 

 
 

Before completing the modeling, detach the work plane from the model using: 

 

Modify > Edit Work Plane > Detach > OK 



 
 

Repeat this process for all cornice elements until you achieve the desired effect and 

confirm the Finish Model. 

 

 

 

3.8. Modeling a Beam Family 

Practical design work in Revit shows that it's worthwhile to create universal component 

families that can be used in multiple instances while maintaining their full functionality and 

parametric capabilities. It's important to note that a wooden structural beam can serve as a beam, 

column, rafter, purlin, brace, beam end, and many other wooden structural elements. 

 

To ensure an optimal model (i.e., not containing too many families), it's advisable to 

create a family that is as universal as possible. In this exercise, a universal beam will be created 

for modeling roof trusses, structural beams, and columns: 



 
 



The "HB_Beam.rfa" family will consist of two families. 

 

The first family (parent/base family) will serve as a pivot/platform capable of rotating 

360 degrees. 

 

The second family (nested) will serve as the beam's geometry, capable of assuming 

different end profile angles and will be loaded into the parent family. 

 

Creating the beam starts with creating the second (nested) family. 

 

To begin, create a new family using the Generic Model (metric) template: 

File > New > Family > Generic Model (metric).rfa 

 
 

In the blank family, switch to the Right Elevation view and for clarity, change the view 

scale to 1:10, and switch the family units (UN) to centimeters. Use reference planes (RP) and 

reference lines to create a sketch for the beam's geometry: 

 
Reference lines will define the start and end of the beam. The start and end points can be 

set at different angles depending on the situation in the model. It's essential to align the reference 

lines with both reference planes using the Align (AL) tool: 

 
 



Next, you'll parametrize the family: 

• Parameter D will control the length of the beam (excluding cuts). 

• Parameter H will control the height of the beam profile. 

• Parameter x will control the angle between the horizontal plane and the cutting plane at the 

start of the beam. 

• Parameter y will control the angle between the horizontal plane and the cutting plane at the end 

of the beam: 

 
 

 Use the Create > Extrusion tool to create a quadrilateral that matches 

the side view of the beam. Attach each edge to the movable reference planes 

and reference lines::  

 

 

 

 



 

 

 
In the Family Types panel, add two additional controlling parameters that will reflect the actual 

angle of the beam's cut at its end and beginning. 

The parameters "x" and "y" will be controlled 

by controlling parameters. The controlling 

parameters (those used in the model during 

modeling) will be named "Lower Cut" and 

"Upper Cut. 

 

 

These parameters will remain in the 

appropriate relationships to control the actual 

angle of the beam cut. 

 

The "Lower Cut" parameter will control 

the "x" parameter. 

 

The "Upper Cut" parameter will control 

the "y" parameter. 

 

This approach will allow the cut 

parameters to take negative values (i.e., be cut 

in the opposite direction): 

 

 

 

 



 

 

 
 

The "D," "H," and "S" parameters should be type parameters, while the rest of the parameters 

should be instance parameters. 

 

Add a "Material" parameter for the beam and associate it with the beam's geometry. 

 

Next, switch to the Reference Level view and execute the familiar Equal binding scheme, 

parametrize the profile symmetrically, and assign it a width "S":  

 

 
To ensure the correct behavior of the nested family within the parent family, select "Based on 

Work Plane" and uncheck the "Always Vertical" option in the Family Category and Parameters panel: 

 



 

 

 
 

This way, the family of beam geometry with cuts is ready to be inserted into the parent family. 

Save the current family as "HB_Beam Geometry.rfa" and proceed to create the parent family.  

To do this, create a new family again using the Generic Model template. 

 

 A highly recommended practice for creating families that 

need to rotate 360 degrees is to use a Profile Rotation as the host. 

This provides a full range of rotation, which can be challenging 

to achieve using lines, planes, angles, extrusions, and other tools 

available in Revit. 

 

It is essential to ensure that the Work Plane is set to the Reference Level. Then, to create a 

rotating host, simply draw any rectangle, where one side will be drawn on the horizontal Reference 

Plane, and the Axis Line will coincide with this side. This indicates that the rectangle is to be a profile 

that will rotate around the Axis Line: 

Next, 



 

 

parametrize the Initial Rotation Angle and Final Rotation Angle and create parameters: 

 

• Final Rotation Angle – will be linked to the "x" parameter, 

• Initial Rotation Angle – will be linked to the "slope" parameter: 

 
Moving to the "Change" > "Family Types" field, you should make the "x" parameter dependent 

on the "slope" parameter. To do this, in the Formula column for the "x" parameter, enter "slope + 20°.". 

It's a good practice to set the "slope" parameter to any value in the range from 1° to 89° (e.g., 33°): 
 

 



 

 

 

Switching to the Right Elevation view, you can 

observe that a kind of incomplete cylinder has been 

created, whose angles are controlled by the 

parameters. One of the cylinder's surfaces serves as a 

Reference Plane for rotating the beam by 360 

degrees. Thanks to this, one family of beams can 

serve as a beam, column, sword, or rafter. 

 

 

 

 

To correctly insert the "HB_Beam Geometry.rfa" family into the parent family, you must first 

change the Work Plane to the cylinder's surface. To do this, use the 3D view: 

 

Then, by going to the "HB_Beam 

Geometry.rfa" family and loading it (as a nested family), Revit 

will prompt you to specify which file the family should be 

loaded into. "Create" > "Load into Project." 

 

Next, place the "HB_Beam Geometry.rfa" family on the 

top surface of the cylinder in such a way that it is oriented 

upwards. Before clicking on the surface, you can rotate the 

beam 90 degrees in each direction using the spacebar key: 

 

 

Then, in flat views (Reference Level and 

Elevation), align the position of the beam so that 

its geometry starts at the intersection of all major 

planes in the family. The Align (AL) tool can be 

used for this operation: 

  



 

 

 

The final step in creating the beam is to assign parameters from the "HB_Beam.rfa" family to 

the nested family "HB_Beam Geometry.rfa." To do this, within the "HB_Beam.rfa" family, select the 

"HB_Beam Geometry.rfa" family, then choose "Edit Type" and assign each parameter its counterpart 

in the "HB_Beam.rfa" family: 

 

• For parameter "D," create a "length" parameter - this will be the length of the beam (set 

it as an element parameter). 

• For parameter "H," create an "H" parameter - this will be the height of the beam profile 

(set it as a type parameter). 

• For parameter "S," create an "S" parameter - this will be the width of the beam profile 

(set it as a type parameter).  

 

 

 
 

Similarly, proceed with the element parameters in the nested family "HB_Beam Geometry.rfa":

  



 

 

 

 

For the "Lower Cut" parameter, create a "Lower Cut" parameter - this will be the angle of the bottom 

cut of the beam (set it as an element parameter). 

For the "Upper Cut" parameter, create an "Upper Cut" parameter - this will be the angle of the top cut 

of the beam (set it as an element parameter). 

 

The family is now ready for loading and modeling in the Point Cloud in the "HB_Tenement" 

file. 

 

 
  



 

 

3.9. Modeling Roof Trusses, Beams, and Columns 

This chapter will outline the principles of modeling roof trusses, beams, and columns using the 

previously created family "HB_Beam.rfa." To begin, model rows of columns, beams, and swords on 

Level 0. It is best to use multiple sections and a 3D view simultaneously. On Level 0, create a section 

that shows one of the trusses, and then model it using the "HB_Beam.rfa" family, using its parameters: 

 

 

 
  



 

 

Next, in the section view, change the display mode of the Point Cloud from RGB to Normal. 

This improves the clarity of the Point Cloud. 

Override Graphics (VG) > Point Clouds > RGB > Normal: 

 

 
 

It is a good practice to insert the loaded "HB_Beam.rfa" family on the plan view (Level 0) and 

then modify its position and parameters in the section. To insert the previously loaded family 

categorized as "Generic Models," go to Architecture > Component and select the "HB_Beam.rfa" 

family from the properties list. Then examine the profile of the modeled column/beam/sword and 

create a new Family Type that reflects the real cross-section profile (e.g., the sword profile is 

approximately 16x16 cm). For each different beam dimension, create a separate family type and name 

it correctly. Then, using the element parameters of the "HB_Beam.rfa" family, adjust it to match the 

Point Cloud: 

 

 
 



 

 

Similarly, you should proceed with modeling the floor 

beams. For this purpose, it's best to use a cross-section of the 

building. 

 

During the modeling of each element, special attention 

should be paid to the fact that in historic buildings, in most 

cases, elements are neither orthogonal nor parallel to each 

other. Therefore, during modeling in the cross-section, it may 

turn out that a beam is in its position in one direction but not 

in the other. 

 

While modeling, it's often necessary to change views, 

from plan to cross-section, from cross-section to perpendicular 

cross-section, adjust the view range in the plan, and frequently 

switch to a 3D view to ensure that each modeled element is in 

accordance with reality. 

  



 

 

When modeling the layout of roof trusses along with the attachment points and swords, the same 

rules apply as in the case of modeling columns and beams. 

 
 

To model the roof, use the Roof tool but operate it as you would with the Floor tool (i.e., use the 

Change Subelements option) to adjust the roof's curvature to match the Point Cloud  

 

 



 

 

3.10. Creating an Example Sheet 

In this exercise, we will create a South Elevation Sheet. To begin creating the sheet, navigate to 

Project Browser > Sheets > New Sheet and choose Metric A1 or another sheet size prepared by you or 

compliant with institutional standards. 

 

 To ensure that the view on the sheet looks 

aesthetically pleasing, you should: 

 

• Turn off model transparency if it was previously 

enabled for modeling purposes. 

• Enable shadows, ambient shadows, and set the 

brightness to a lower value than the default (e.g., 15-

20). 

• Set a gradient background with appropriate colors. 

• Disable the Thin Lines (TL) option. 

• Outline the Ground Line with a <Wide Lines> detail 

line, then edit the view's crop region to align with 

the ground line. 

• Hide the Sections and Levels category. 

• Add system or custom elevation markers. 

• Include necessary elevation descriptions. 
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